Нет звука во флэше?


Иногда мне, как «продвинутому» задат такие интересные вопросы… Причём, по проблемам, о существовании которых я даже и не подозревал.
Сегодня звонит Mitritch. Так, мол, и так… Не работает звук во флэше. В firefox. Картинка есть, а звука нет.
Ну, думаю, фигня какая: переустановить flashplayer и дело в шляпе!
Фиг!

Оказалось, что Mitritch его же переустанавливал — не помогло. Ладно, давай проверим в других браузерах… В IE работает?
Оказалось, что IE просит что-там доустановить, но Mitritch отказался. И тут он так ненароком вспоминает, что ещё и Avast перестал выводить звуковые уведомления о новой базе (кто не в курсе — Avast весьма громогласно так объявляет, что «База обновлена»). Я даже как-то растерялся… Одно дело, когда онлайновый звук не работает, и совершенно другое, когда установленное приложение не воспроизводит звуки с винчестера. Это уже вряд ли проблема флэша, скорее — трабл винды.
Вобщем, послал Mitritch’а ставить то, что просил IE (так, на всякий случай), а сам полез гуглить. Оказалось, проблема довольно распространённая.
Не воспроизводятся:

  • системные звуки (да-да, звуки самой винды);
  • звуки во флэше (независимо от браузера);
  • звуки во многих интернет-приложениях (например, в скайпе);
  • звуки в онлайновых играх;
  • и т.д…

Звоню Mitritch’у: звуки при входе/выходе винды есть? НЕТ!!!
Замечательно. Самое замечательное то, что моё гугление толком ни к чему не привело: однозначного лекарства я не смог найти. Некоторым помогло следующее:

  • становить K-lite (если ещё не установлен);
  • запустить codec tweak tool и выбрать ключ Fix non-working system sound (или Fix broken sound(Midi, WaveOut) — в разных версиях по-разному).

Лично у меня этот ключ неактивен (но у меня и проблемы такой нет — ттт).
Как мне видится, проблема либо в каком-то кодеке, либо библиотечке. Возможно, что даже и по вине flashplayer’а.
Что бы я сделал?
Для начала — правильно удалил Adobe Flash Player и поставил последнюю версию. Поставил последний K-Lite Codec Pack.
Не факт, что поможет, но попроовать стоит. Ну и прогнать эту самую codec tweak tool…
PS Как я понял, проблема в winmm.dll (C:\WINDOWS\system32 и E:\WINDOWS\system32\dllcache). Может, её просто заменить? О_о
Или проверить права (у SYSTEM должен быть полный доступ)?

Комментарии:

30 comments

    замена не поможет, так как скорее всего где-то что-то неправильно прописалось, и эта библиотека (если дело в ней) просто не запускается.
    просто так ничего не бывает, вероятно он установил что-то до того как началась беда. Искать нужно там 🙂

      Да когда один комп не несколько человек — не отследишь, кто там и что поставил…

    выстроить в ряд направить дуло, пускай признаются =)))
    Но честно говоря сам с такой проблемой еще не сталкивался ни разу…

      Да вот и я не сталкивался. А начал гуглить — офигел…

    Чем «блох» вылавливать проще систему переустановить…
    Что и будет сделано в ближайшее время… 😉

      Всё же, было бы интересно понять))

    Дима, для меня это уж слишком сложно… 😀

      Митрич, зато есть к чему стремиться! 😉

    пи…иц!
    удалить на-пииии… винду и поставить убунту, блин.
    линукс очень сложный, да?

      маяк, да не кипятись ты… Народ пугается… И самого линукса, и новых (неизвестных) траблов с ним… А самое страшное — виндовый софт не работает под ним. Это сродни тому, как сорваться в совершенно другой город на ПМЖ.

      ЗЫ Хотя, Митричу не привыкать! 😉

    Дима, ты же знаешь, что я стремительный 😀 , но не до такой степени, чтобы сменить операционную систему… 😀

      Митрич, тебе один фиг сейчас переставлять! А может… 😉

    Дима, «маленький» нюанс: компутер не мой… 😀

      Да, тогда сложнее))) С тобой мы бы ещё могли договориться)))

    Dandr, каких траблов-то? Всё же просто работает, и хорошо работают.
    И виндовые программы вполне себе работают под вайном, никак не хуже чем под виндой — некуда! 🙂

      Это ты знаешь, я знаю. А они — нет. А неизвестность — она пугает. 🙂

    А скока ещё слов незнакомых (!!!) 😯

    Тебя бы всё хихикать на старым… 😀

    Mitritch, щас тебе маяк расскажет про своих бабушек! 😉

      А мог бы простимулировать! 😉

    а в playback control звук wave не на нуле ? ))

    у меня проблема та же самая !!!! переустановка винды не чего не даёт…к сожалению… а вот на счёт библиотеки автора прошу по подробней написать решение !!!!! с уважением ко всем!!! pity

      переустановка винды не чего не даёт…

      Боюсь, при таком раскладе и замена библиотеки ничего не даст. А изначально звук был?

    Moralist, cкажите, пожалуйста, а где находиться этот параметр playback control звук wave, о котором вы писали? вроде в «панели управления» в «звуках и аудиоустройствах» такого нету…

    Переустановил ОС звук пришёл… 🙂

    Moralist, cкажите, пожалуйста, а где находиться этот параметр playback control звук wave, о котором вы писали? вроде в “панели управления” в “звуках и аудиоустройствах” такого нету…

    именно там и есть. Звук — громкость — громкость микшера — дополнительно

Добавить комментарий

Shopping cart

0

No products in the cart.

%d такие блоггеры, как: